๐๖ กันยายน ๒๕๕๓

Config Network ของ WRT54GL ที่อัพเดทเฟิร์มแวร์เป็น OpenWRT แล้ว


  ขอบคุณภาพด้านบนนี้จาก http://www.electoday.com 


แผนผังการต่อเน็ตเวิร์คของผม


 การคอนฟิคส่วนของ Network   (ของผมกำหนดเลขแบบ Static ครับ ถ้าใครใช้แบบ DHCP อย่าทำตามนี้น่ะ)

พิมพ์คำสั่ง # vi /etc/config/network 

#### VLAN configuration
config switch eth0
    option vlan0 "0 1 2 3 5*"
    option vlan1 "4 5"

#### Loopback configuration
config interface loopback
    option ifname "lo"
    option proto static
    option ipaddr 127.0.0.1
    option netmask 255.0.0.0

#### LAN configuration
config interface lan
    option type bridge
    option ifname "eth0.0"
    option proto static
    option ipaddr
192.168.1.1    <--- แก้ไขเลข IP ของ "LAN" โดยการเปลี่ยนตัวเลขตรงนี้
    option netmask
255.255.255.0

#### WAN configuration
config interface wan
   
option ifname "eth0.1"
    option proto static (แก้ข้อความตรงนี้ เพื่อที่จะกำหนดเลข IP เอง คือของเดิมเป็น dhcp แก้เป็น static )
    option ipaddr
172.16.20.12    <--- แก้ไขเลข IP ของ "WAN" โดยการเปลี่ยนตัวเลขตรงนี้

     option netmask
255.255.255.0
     option dns
172.16.20.1    <--- แก้ไขเลข IP ของ DNS ตามความเป็นจริง
     option gateway
172.16.20.1    <--- แก้ไขเลข IP ของ Gateway ตามความเป็นจริง

 ข้างล่างนี้จำทำก็ต่อเมื่อต้องการให้ WRT54GL เป็น Wireless Client เท่านั้น 
#### Wireless configuration  <--- หัวข้อนี้ลอกมาจาก http://wiki.personaltelco.net/OpenWRT (19 พ.ค. 2554) 
config interface wireless
    option ifname "wl0"
    option proto
static
    option ipaddr
192.168.1.1    <--- แก้ไขเลข IP ของ "วง LAN" โดยการเปลี่ยนตัวเลขตรงนี้
    option netmask
255.255.255.0


  ข้างล่างนี้เอาไว้เผื่อว่าจะลองเล่นกันดู  

 การคอนฟิคให้ WRT54GL ทำหน้าที่เป็นตัวปล่อยสัญญาณไวร์เลส (WLAN) 
 (แบบไม่ต้องใส่พาสเวิร์ด)

พิมพ์คำสั่ง # vi /etc/config/wireless 

config wifi-device wl0
    option type broadcom
    option channel
5 <----- ระบุช่องความถี่ออกอากาศของ wireless (ค่าจะอยู่ระหว่าง 1 ถึง 11)

    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled
0 <----- ถ้าเปิดใช้งาน wireless ให้กำหนดเป็นเลข 0 และถ้าจะปิดการใช้งาน wireless ให้กำหนดเป็นเลข 1 
                                       หรือใส่เครื่องหมาย # หน้าบรรทัด หรือลบบรรทัดนี้ทิ้งไปเลยก็ได้ 


config wifi-iface
    option device wl0
    option network lan
    option mode ap
    option ssid
Samila <---- ตั้งชื่อ SSID ของ Wireless (อ่านว่า สมิหลา)
    option encryption
none <---- บ่งบอกว่าไม่มีการกำหนดพาสเวิร์ดตอนที่เอาเครื่องโน๊ตบุ๊ค connect กับไวร์เลสตัวนี้


 การคอนฟิคให้ WRT54GL ทำหน้าที่เป็นตัวปล่อยสัญญาณไวร์เลส (WLAN) 
 (กรณีต้องการให้ผู้ใช้ใส่พาสเวิร์ดแบบ web)

พิมพ์คำสั่ง # vi /etc/config/wireless 

config wifi-device wl0
    option type broadcom
    option channel
5 <----- ระบุช่องความถี่ออกอากาศของ wireless (ค่าจะอยู่ระหว่าง 1 ถึง 11)

    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled
0 <----- ถ้าเปิดใช้งาน wireless ให้กำหนดเป็นเลข 0 และถ้าจะปิดการใช้งาน wireless ให้กำหนดเป็นเลข 1 
                                       หรือใส่เครื่องหมาย # หน้าบรรทัด หรือลบบรรทัดนี้ทิ้งไปเลยก็ได้ 


config wifi-iface
    option device wl0
    option network lan
    option mode ap
    option ssid
Samila <---- ตั้งชื่อ SSID ของ Wireless (อ่านว่า สมิหลา)
    option encryption
wep  <---- กำหนดการใส่พาสเวิร์ดแบบ web
    option key
Songhkla90000 <---- กำหนดพาสเวิร์ดที่ผู้ใช้ต้องป้อนในช่วงที่เอาเครื่องโน๊ตบุ๊ค connect กับไวร์เลสตัวนี้ 
                                                 
( พาสเวิร์ดที่ต้องป้อนคือ Songhkla90000 )

 


 การคอนฟิคให้ WRT54GL ทำหน้าที่เป็นตัวปล่อยสัญญาณไวร์เลส (WLAN) 
 (กรณีต้องการให้ผู้ใช้ใส่พาสเวิร์ดแบบ psk2)

พิมพ์คำสั่ง # vi /etc/config/wireless 

config wifi-device wl0
    option type broadcom
    option channel
5 <----- ระบุช่องความถี่ออกอากาศของ wireless (ค่าจะอยู่ระหว่าง 1 ถึง 11)

    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled
0 <----- ถ้าเปิดใช้งาน wireless ให้กำหนดเป็นเลข 0 และถ้าจะปิดการใช้งาน wireless ให้กำหนดเป็นเลข 1 
                                       หรือใส่เครื่องหมาย # หน้าบรรทัด หรือลบบรรทัดนี้ทิ้งไปเลยก็ได้ 


config wifi-iface
    option device wl0
    option network lan
    option mode ap
    option ssid
Samila <---- ตั้งชื่อ SSID ของ Wireless (อ่านว่า สมิหลา)
    option encryption
psk2  <---- กำหนดการใส่พาสเวิร์ดแบบ psk2 (หรือเรียกอีกอย่างหนึ่งว่า WPA2 Pre-shared Key)
    option key
Songhkla_Hadyai <---- กำหนดพาสเวิร์ดที่ผู้ใช้ต้องป้อนในช่วงที่เอาเครื่องโน๊ตบุ๊ค connect กับไวร์เลสตัวนี้ 
                                                    
( พาสเวิร์ดที่ต้องป้อนคือ Songhkla_Hadyai )


 การคอนฟิคให้ WRT54GL ทำหน้าที่เป็นตัวรับสัญญาณไวร์เลส (Wireless Client) 
อันนี้ก็อบมาจากเวบบอร์ด 100 วัตต์ ( http://www.100watts.com/smf/index.php?topic=74648.msg382704#msg382704)
โดยท่าน E20GMY (ขอขอบคุณครับ)

 จากหัวข้อคำถามจากเพื่อนสมาชิก 
อยากทราบวิธีตั้งค่า wrt54gl+aprs4r เวลาใช้งาน wireless ให้เป็นโหมด client ครับ

 ท่าน E20GMY ได้แนะนำว่า...    (เพื่อความมันส์ในการอ่าน ผมได้แต่งเติมอีกนิดหน่อย) 

- # vi /etc/config/wireless <-- พิมท์คำสั่งเพื่อเข้าไปทำการแก้ไขในส่วนของ Wireless
- option disabled 1 <-- แก้เป็น 0
- option mode ap <-- แก้เป็น option mode sta ( mode ap = Access Point , mode sta = Client Wireless )
- option ssid OpenWrt <-- ใส่ SSID ของไวร์เลสทางนั้นลงไป (คือ SSID ของตัว Accesspiont ที่ปล่อยสัญญาณออกมาให้เราเกาะนั่นเอง)
- option encryption none <-- แก้เป็น option encryption wep
- option key  xxxxxxxxxx <-- เป็น Hex โดยไปตรงนี้ http://www.andrewscompanies.com/tools/wep.asp
ดูตรง Custom WEP key ใส่ password ลงไปตรงช่อง Custom Phrase ซึ่งปรกติจะเป็น 13 ตัวอักษร 
แล้วคลิกปุ่ม generate custom key แล้วไปก๊อป ตรงช่อง HEX ข้างล่างเอามาใส่
- ได้แล้วก็เซฟ แล้วออกจากหน้าจอแกไข แล้วก็รีบู๊ตดูทีนึง ถ้าถูกต้อง ไฟ WLAN ต้องติดขึ้นมา แล้วก็น่าจะติดต่อได้แล้ว

 

แถมอีกซักตัวอย่าง (กรณีเซ็ตอัพให้ Wrt54gl ที่ลง OpenWRT แล้ว ให้ทำหน้าที่เป็น WiFi โหมด Client) อันนี้ลงมือทำเอง

- option disabled 0 <-- ของเดิมเป็น 1 ให้แก้เป็น 0
- option mode sta <-- ของเดิมเป็น ap ให้แก้เป็น sta ( mode ap = Access Point , mode sta = Client Wireless )
- option ssid "Samila" <-- ใส่ SSID ของไวร์เลสทางนั้นลงไป (คือ SSID ของตัว Accesspiont ที่ปล่อยสัญญาณออกมาให้เราเกาะนั่นเอง)
- option encryption psk2 <-- ของเดิมเป็น none แก้เป็น psk2
- option key 
"Songhkla_Hadyai" <-- กรณีที่ encryption เป็น psk2 ตรง key นี้ให้เราพิมพ์ตัวอักษรปกติลงไปตรง ๆ ได้เลย 
                                                     (ไม่ต้องเอาไปเข้ารหัสแบบ ตัวอย่างข้างบน)
- ได้แล้วก็เซฟ แล้วออกจากหน้าจอแก้ไข แล้วก็รีบู๊ตดูทีนึง ถ้าถูกต้อง ไฟ WLAN ต้องติดขึ้นมา แล้วก็น่าจะติดต่อได้แล้ว


 การคอนฟิค DHCP กรณีที่ต้องการให้ WRT54GL ทำหน้าที่จ่ายเลข IP ให้เครื่องอื่นด้วย  

พิมพ์คำสั่ง # vi /etc/config/dhcp 

config dhcp
    option interface
lan   <-- จ่ายเลข DHCP ออกทาง LAN
    option start
100   <-- เริ่มจ่าย DHCP ตั้งแต่เลข 100
    option limit
15   <-- จ่ายเลขทั้งหมด 15 เลข (192.168.1.100 ถึง 192.168.1.115 )
    option leasetime
12h   <-- กำหนดเวลาหมดอายุของเลข IP ที่จ่ายออกไป (12 ชั่วโมง)

config dhcp
    option interface wan
    option ignore 1


=== Network restart ===(การสั่งให้ระบบเน็ตเวิร์คทั้งหมดรีสตาร์ทใหม่)

พิมพ์คำสั่ง # /etc/init.d/network restart 


=== Closed DHCP ===(การสั่งให้ระบบจ่ายเลข IP หยุดทำงาน)

พิมพ์คำสั่ง # /etc/init.d/dnsmasq disable 
(จะมีผลหลังจากรีสตาร์ทแล้ว)


=== Restart WRT54G ===(การสั่งให้เครื่อง WRT54G เริ่มทำงานใหม่ทั้งหมด)

พิมพ์คำสั่ง # reboot 


Packages

Additional features or utilities can be added via the ipkg system.

ipkg update
ipkg list
ipkg install <package>
ipkg remove <package>

( http://ftp.osuosl.org/pub/nslu2/releases/OpenWrt-kamikaze-7.09-README.txt  )


  การคอนฟิกค่าด้านเน็ตเวิร์ค ด้วย Command Line  

Page Description
3g/UMTS Stick Use 3g/UMTS USB Dongle for WAN connection
Wireless configuration Wireless configuration
Bridged AP Howto bridge wireless and ethernet in Access Point mode
Routed AP Howto to put wireless and ethernet in different subnets
Client Mode General discussion of client mode wireless
Routed Client Howto configure a routed or masqueraded wireless client
Bridged Client (Broadcom) Howto define a wireless client bridge with proprietary Broadcom drivers
WDS (Broadcom) Howto define AP-to-AP WDS with proprietary Broadcom drivers
WDS (Atheros) Howto setup AP-to-Sta WDS with madwifi and mac80211 drivers
Multi-SSID Howto define multiple virtual Access Points

 อื่น ๆ ที่พอหาอ่านได้ 

http://www.stacksegment.net/wiki/index.php/OpenWRT

การจัดการ Firewall ใน OpenWRT
http://garnet.cpe.ku.ac.th/~g5085036/blog/wordpress/category/openwrt/ 

การคอนฟิกค่าอื่นๆ (ลองอ่านแล)
http://theinterw3bs.com/wiki/index.php?title=OpenWRT_for_the_WRTSL54GS_and_WRT54GL#Hostname_and_Timezone

การคอนฟิค Wireless
http://josefsson.org/openwrt/wlan.html